Skip to main content Skip to footer

  • Alert Me
  • Print
Download

PSP Audioware FETpressor (Download)

  • Write a Review

FETpressor from PSP Audioware is a FET feedback-type compressor plug-in designed to provide accurate, instant compression with lots of character. Gre...Click To Read More About This Product

Download After Purchase!

  • Your Price :
    $99.00
Add to Cart

Availability: 

After finalizing your order for this downloadable product you'll receive an activation key via email. This email will include a product link and directions for downloading.(Credit approval may take up to 24 hours.)

SKU 
L83566000000000
Add to Wish List

Earn up to 495 reward points.

OVERVIEW

Powerful plug-in inspired by '70s style compressors.

FETpressor from PSP Audioware is a FET feedback-type compressor plug-in designed to provide accurate, instant compression with lots of character. Great for vocals, guitars, bass, drums and whenever a classic 1970s-style FET compressor is needed, the PSP FETpressor contains an internal side chain high-pass filter to control amount of low-frequency pumping, smoothly adjustable compression ratio, the ability to select which channel to process and a link switch. This compressor also contains a dry signal blend for parallel compression, plus makeup amplifier and output transformer emulations to add subtle character even when set to a 1:1 ratio.

MPN: 1035-1201

Download PSP FETpressor today.

SPECIFICATIONS
PC System Requirements

  • VST3
  • Windows x32 or x64 (7, 8 or 10)
  • VST3 compatible application
  • VST
  • Windows x32 or x64 (XP Service Pack 2, Vista, 7, 8 or 10)
  • VST 2.4 compatible application
  • RTAS
  • Windows x32 or x64 (XP Service Pack 2)
  • ProTools LE 8.0.0 or ProTools TDM 8.0.0 (or later)
  • AAX
  • Windows x32 or x64 (XP Service Pack 2, Vista or 7 or 8 or 10)
  • Pro Tools 10, Pro Tools 11 or Pro Tools 12 (or later)
Mac (Intel) System Requirements

  • AudioUnit
  • Mac OS X 10.6–10.11 or later
  • 32- or 64-bit host application capable of running AudioUnit plug-ins with Cocoa view
  • VST
  • Mac OS X 10.6–10.11 or later
  • 32- or 64-bit VST 2.4 compatible host application
  • VST3
  • Mac OS X 10.6–10.11 or later
  • 32- or 64-bit VST 2.4 compatible host application
  • RTAS
  • Mac OS X 10.6–10.11 or later
  • ProTools LE 8.0.0 or ProTools TDM 8.0.0 (or later)
  • AAX
  • Mac OS X 10.8–10.11 or later
  • Pro Tools 11, 12 or later

This oversized item has special shipping requirements

Restrictions

Reviews
Questions & Answers View All
Loading....
Questions & Answers
Customer Service

Sign up for the latest deals!

You are changing the Ship-To country.

Our product catalog varies by country due to manufacturer restrictions. If you change the Ship-To country, some or all of the items in your cart may not ship to the new destination.