Skip to main content Skip to footer
Get 15% Off Select Orders, No Minimum or Call 800-348-5003 For Even Better Deals

  • Alert Me
  • Print
Download

PSP Audioware PSP HertzRider 2 (Download)

  • Write a Review

PSP HertzRider is a frequency shifter plug-in from PSP Audioware. It can be an incredible tool for tuning inharmonic sounds like snares yet for harmo...Click To Read More About This Product

Download After Purchase!

  • Your Price :
    $69.00
Add to Cart

Availability: 

After finalizing your order for this downloadable product you'll receive an activation key via email. This email will include a product link and directions for downloading.(Credit approval may take up to 24 hours.)

SKU 
L89335000000000
Add to Wish List

Earn up to 345 reward points.

OVERVIEW

Versatile plugin for frequency shifting.

PSP HertzRider is a frequency shifter plug-in from PSP Audioware. It can be an incredible tool for tuning inharmonic sounds like snares yet for harmonic sounds it becomes a creative and crazy destructive tool. In addition to a wide range of shifting settings, the algorithm contains an LFO (low frequency oscillator) to provide interesting modulation options allowing you to further creatively experiment with this tool. PSP HertzRider is designed to be as simple as possible, to use as few resources as possible and to incur only a very slight (and frequency dependent) latency.

MPN: 1035-1371
FEATURES
  • Far more control over how the transients sound
  • Transparent results
  • Neat and tidy interface
  • Three dedicated transient-handling modes
  • Clear metering, including K-System support

Download HertzRider 2 today.

SPECIFICATIONS
  • Up to date iLok License Manager application installed
  • PC
    • Windows x32 or x64 (7, 8 or 10)
    • VST3 compatible application
    • VST 2.4 compatible application
    • ProTools 8.0.0 (or later)
    • Pro Tools 10, 11, 12 or Pro Tools HD 10, 11, 12 or Pro Tools 2018
    Mac
    • Mac OSX 10.8 - 10.14 or later
    • 32 or 64-bit compatible host application
    • 32 or 64-bit VST 2.4 compatible host application
    • 32 or 64-bit VST 3 compatible host application
    • ProTools LE 8.0.0 or ProTools TDM 8.0.0 (or later)
    • Pro Tools 10, 11, 12 or Pro Tools HD 10, 11, 12 or Pro Tools 2018

    This oversized item has special shipping requirements

    Restrictions

    Reviews
    Questions & Answers View All
    Loading....
    Questions & Answers
    Customer Service

    Sign up for the latest deals!

    2022© Woodwind & Brasswind. All rights reserved.     Do Not Sell My Info (CA Only) | Terms & Conditions | Privacy Policy | Accessibility Statement

    You are changing the Ship-To country.

    Our product catalog varies by country due to manufacturer restrictions. If you change the Ship-To country, some or all of the items in your cart may not ship to the new destination.